This project is read-only.

VS 2010 RTM supported?

Apr 19, 2010 at 5:04 PM

Does this work with the release version of VS 2010?

Apr 24, 2010 at 7:15 PM

Yes it does.

May 13, 2010 at 11:54 AM
I've just installed 1.0.8d and it doesn't show up in VS 2010. I'm on W7 x64 and have TortoiseHg installed.
May 13, 2010 at 3:05 PM
You probably have to change the source control plugin. Tools -> Options -> Source Control -> Current source control plug-in.
May 13, 2010 at 3:06 PM
Ah, that's it, excellent, thanks!
Oct 28, 2010 at 11:50 AM
Edited Oct 28, 2010 at 12:00 PM

Doesn't work for me.

Have tried uninstalling / reinstalling visualhg.

VS 2010 Version 10.0.30319.1 RTMRel Premium.

Windows 7 Enterprise x64

I have VisualHG 1.1.0 installed.

The toolbar is inactive.

There is no VS context menu.

Seems to work in VS 2008 though.

What would be causing this?

Oct 29, 2010 at 3:55 PM

Restart (warstart) your PC after installing TortoisHG, than it should work.


Oct 29, 2010 at 11:18 PM

Yep, tried all the glaringly obvious windows work arounds.
What have I missed?

Did a presentation on hg yesterday, this will be one of the things that stops the devs giving their vote.
If we can get this going, it should be a relatively easy sell.

Thanks for any help you can provide.

Oct 30, 2010 at 7:17 AM

Although works fine on my home system.

Any ideas?

Oct 30, 2010 at 8:58 AM

The overlay icons work in VS, but the context menu has no VisualHG icons and the VisualHG toolbar has all the buttons greyed out.

Oct 30, 2010 at 9:43 AM

It is necessary to uninstall prev version of VisualHG first by calling the deinstaller.

Unfortunately the installer does not solid deinstall previous versions of VisualHG.

So you could have two versions of VisualHG installed and you may ran into

the same hassle that was discussed here -

I hope that helps, Bernd


Oct 30, 2010 at 11:55 AM

Yip, that did it :-)

Thanks berndschrader!